Apache Wicket 7.x

Here you can learn about the status of Wicket 7.x, find links to download it, learn how to configure your Maven POM to use Wicket, find the minimal requirements, and migrate your existing application to this Wicket version.

Status

The status for Wicket 7.x is: supported.

This is the current stable, production ready release of Wicket. All projects intended for production use should use this version.

Semantic versioning

These releases follow semantic versioning so upgrades between minor releases will not break compatibility.

Change log

To see what changed in these releases you can read the change log.

Download

The most recent release in this branch is: 7.8.0. You can get the release using Maven or download it manually.

Using Apache Maven

Use the following Maven dependency to use Wicket in your project:

<dependency>
    <groupId>org.apache.wicket</groupId>
    <artifactId>wicket-core</artifactId>
    <version>7.8.0</version>
</dependency>

Add the snippet above to your project’s POM in the dependency (management) section.

You can add more Wicket modules to your project by adding more dependencies (copy above snippet and change the artifactId accordingly).

If you are not a Maven user, you can download the Wicket release manually.

Download Manually

Use the following links to download Wicket manually to build Wicket from source:

Or use the following links to get the pre-packaged binaries instead:

Note that the binary packages and the source packages don’t contain any dependencies necessary to have your project working out of the box. We strongly urge you to use Maven (or Buildr, or Gradle) as your dependency management system.

Older releases

The Apache mirroring system only hosts the latest version of each actively supported branch. When you need to download an older release you can find them in the archives.

Go to the Apache archives to find your specific version.

Requirements

Apache Wicket has few requirements in order to work properly. In this section you’ll find the minimum requirements for all Wicket modules. Specific modules may need additional libraries, such as file upload, date time APIs, CDI specifications, and more. See the module’s POM for more details on the necessary libraries.

Java version

This Wicket version requires at least the following Java version: JDK 7.0 or newer.

Not only is a particular version of Java necessary, Wicket also needs access to specific APIs.

Servlet API

This Wicket version requires at least the following Servlet API version: Servlet API 3.0 or newer. This is provided by your container, please see the documentation of your container to see which version of the Servlet specification is supported.

In addition to the Servlet API, Wicket uses SLF4J to let you choose your own implementation of a logging framework.

Logging

You cannot use Wicket without adding an SLF4J logging implementation to your classpath. Most people use log4j.

If you do, just include slf4j-log4j12.jar on your classpath to get Wicket to use log4j too. If you want to use commons-logging or JDK14 logging or something else, please see the SLF4J site for more information.

Don’t mix Wicket versions

You cannot mix different Wicket versions in your project. You should always use the artifacts from a particular release. For example it is not possible to use Wicket Extensions 1.5 in a Wicket 6 project, or Wicket CDI 6.19 in a Wicket 7 project. The same goes for 3rd party libraries: make sure you always use a compatible version of your 3rd party library.

Migrating from earlier versions

If you are migrating an existing application from earlier versions of Wicket you may find our migration guides invaluable: